1.0.0 IS OUT SERVER OUTDATED!

View previous topic View next topic Go down

Updates are not easy

Post  Admin on Sat Nov 19, 2011 6:08 am

Bukkit needs to be update. Bukkit team gets server 1.0 and goes through its code, and painstakingly makes all amendment that are required. Took 1 - 2 weeks going from 1.7 to 1.8. Once Bukkit is updated to 1.0 release, all the pluggins need to be updated to be compatible with the new version of Bukkit. There are also the inevitable bugs and glitches. Then I may have to make changes to config files of pluggins (or even bukkit its self) due to internal changes. Some pluggins may not get updated, and I will have to find similar ones, or go without.
On previous updates:
- chestlock got replaced with LWC
- permissions got replaced by groupmanager (part of essentials), then in another update had to change of permissionbukkit (due to pluggin incompatibility).
- citizen trader replaced by local shops, which then did not get updated for the next bukkit release. Had to stick with iConomy 5 instead of 6 to keep functionality. Later replaced with Command Shops (others took over the local shops project and renamed it).
There may be a whole host of things that I have to do, so I'm going to keep it cool, and I ask all residents of Cobble Creek to be patient.
I will learn all I can while waiting for bukkit 1.0 . The server will be backed up (in a number of locations, as well as all pluggins and config files), and the server will be off line for a time (couple of days to a week) while I get most functionality back. Tweaking and frequent server restarts will ensue for a couple of weeks after that, but fingers crossed, should end up being even more awesome.
Just in case anyone missed the main message in this post... UPDATING THE SERVER IS A VERY BIG DEAL!
In the mean time:
1. Update to 1.0 and wait for Cobble Creek to come back on line, OR
2. Stay with 1.81 and enjoy Cobble Creek, and wait for 1.0 server (and 1.0 single player), OR
3. Create another account on your computer. Don't update with your current account. Install minecraft on the new account and update to 1.0. If you feel like single player in 1.0, play in your new account. If you feel like hanging in Cobble Creek, play with your main account.
Option 3 is what I'll be doing.
avatar
Admin
Admin

Posts : 339
Points : 532
Join date : 2011-09-25

http://cobblecreek.dogsboard.com

Back to top Go down

R U SERIUS BLAKE...

Post  SnowGolem1 on Sat Nov 19, 2011 2:59 am

thats why u dont update untill the server does
believe it or not updating is not easy especially for a craftbukkit server

you need to install all the plugins and crap , and wait before you can even do that for craftbukkit to release 1.0.0

if you expect saxburger to update all this withing 1 day of its release your dreaming

its hard enough to update SinglePlayer and add all the mods you had.

if you have replaced your minecraft 1.81 jar then you can have my one here
No mods , except otifine , oh and the HD teture patch (so u can use hd textures )



My MINECRAFT 1.8 JAR
avatar
SnowGolem1

Posts : 111
Points : 203
Join date : 2011-10-11
Age : 20
Location : New South Whales

Back to top Go down

1.0.0 IS OUT SERVER OUTDATED!

Post  Chaotic_Rage on Sat Nov 19, 2011 12:03 am

1.0.0 has been released for minecraft server has to be updated!
avatar
Chaotic_Rage

Posts : 65
Points : 135
Join date : 2011-10-22
Location : Waratah, Newcastle

Back to top Go down

Re: 1.0.0 IS OUT SERVER OUTDATED!

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum